Solved TD-23864 [TD6.n , TD7.0.n] Type-Ahead ( autofill ) for Colour ComboBoxes not working

Post found bugs and possible workarounds.
Steve Leighton
Site Admin
Site Admin
New Zealand
Posts: 29
Joined: 05 Mar 2017, 20:57
Location: Tauranga, New Zealand

TD-23864 [TD6.n , TD7.0.n] Type-Ahead ( autofill ) for Colour ComboBoxes not working

Post by Steve Leighton » 08 Jan 2018, 02:44

Type-Ahead (autofill) does not work in a Colour ( Visual Toolchest ) ComboBox .

Works fine in a standard Combo , but not in a Colour Combo ( either derived from cColorComboBox or by adding:

Code: Select all

On VTM_Create
 	Call VisListSetStyle( hWndCombo,LBS_VisExtensions ,lParam )
 
to a standard Combo, to allow Colours.

Type-Ahead ( autofill) does not work in any version from v5 thru v7.0.n for Colour Combos.
Created Defect TD-23864 for this issue. Fix due TD7.1
Best wishes
Steve
Bankside Systems Ltd. ( New Zealand )
www.banksidesystems.co.uk

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 400
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: TD-23864 [TD6.n , TD7.0.n] Type-Ahead ( autofill ) for Colour ComboBoxes not working

Post by Dave Rabelink » 14 Feb 2018, 07:45

This issue is fixed in TD 7.0.4
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

Return to “Bug Reports”

Who is online

Users browsing this forum: Ccbot [Crawler] and 0 guests