[TD71] TD-24063: Large selections in TD71 IDE can not be commented due to hanging IDE

Post found bugs and possible workarounds.
Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 484
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

[TD71] TD-24063: Large selections in TD71 IDE can not be commented due to hanging IDE

Post by Dave Rabelink » 12 Jun 2018, 10:24

Large selections in TD71 IDE can not be commented due to hanging IDE.

The testcase shows the issue.

- Select all classes in classes section
- Comment them

It takes a while before the waitcursor ends and the IDE GUI seems to be finished.
But then try to use the source. At this moment, TD IDE hangs and shows high CPU usage in taskmanager.

Maybe the IDE will come back, but I tried waiting several minutes but it did not.

The test source is saved in TD70 format. So can be tested in TD70.
On that version, the IDE can immediately be used after commenting the block of code.

CommentHangs_TD70.zip

This defect is registered as:

Ticket # 3777667
You do not have the required permissions to view the files attached to this post.
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 484
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: [TD71] TD-24063: Large selections in TD71 IDE can not be commented due to hanging IDE

Post by Dave Rabelink » 18 Jun 2018, 05:07

OpenText assigned this defect number:

TD-24063: TD IDE hangs after commenting large blocks of code
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

Igor Ivanovic
Site Admin
Site Admin
Croatia
Posts: 133
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

Re: [TD71] TD-24063: Large selections in TD71 IDE can not be commented due to hanging IDE

Post by Igor Ivanovic » 19 Jun 2018, 05:08

I tried you example and indeed TD7.1 hangs.
But it did come back after some time.
I didn't close it, as I had some other stuff to do, and when I come back it was alive again.
It could took anything between 3 to 60 minutes, don't really know as I was away, but it eventually come back.
Igor Ivanovic
Image

Return to “Bug Reports”

Who is online

Users browsing this forum: Ccbot [Crawler] and 0 guests