sqlbase 11.02 shutdown

forum.sqlbase (2000-2010)
NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 23 Feb 2009, 12:24

 Posted by:  Fabrizio Petrini 

hi,
we have updated our sqlbase engine from 8.5 to 11.02 and now we are little
bit worried because our database shutdown and we don't know the reason.
we have attached the sql fail file if somebody want to check and help us.

Thanks.
Fabrizio Petrini

NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 23 Feb 2009, 13:45

 Posted by:  Rainer Ebert 

Have you installed a service pack (like SP2 or SP3) over SB11.0.2? If not,
try this. If I remember correctly, there were internal locking problems with
SB11.0.2 without SP.

Regards,
Rainer

NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 23 Feb 2009, 15:01

 Posted by:  Fabrizio Petrini 

Thanks Rainer,
i've installed service pack 3 ( i hope it include service pack 1 and 2 )
from sqlbase engine about window i see this version version: 11.0.2.5669
Fabrizio

NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 23 Feb 2009, 16:59

 Posted by:  Fabrizio Petrini 

btw
with this version ( sqlbase 11.02 sp3 ) from sqlconsole appear a lot of
locks expecially from stored procedure process.
the sql keyword autolocktable is: autolocktable=1.
we don't know what to do and we are very worried because with 8.5 we haven't
this problem.
I hope somebody help me.

Fabrizio Petrini

NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 23 Feb 2009, 17:17

 Posted by:  Rainer Ebert 

Hi,

in sql.ini set
- autolocktable=0
- readonly=0
- cache=64000 (not more!)
and remove a sortcache setting.

(Especially if you don't want to use the new isolation level RC.)

Regards,
Rainer

NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 24 Feb 2009, 15:59

 Posted by:  Fabrizio Petrini 

Hi Rainer,
I changed nothing, i've only upgraded my 8.1 version to 11.02 sp3, all the
keywords in my sql.ini are as you wrote. I only tried to change
autolocktable because i read that with it i should receive less deadlock.
Actually when i receive a deadlock error even if i execute the rollback
command the session stay locked. I've only one way, close the process from
sqlconsole. I've only one doubt: one application server still use 8.1 client
library to open a 11.02 connection, could it be a problem?
Thanks
Fabrizio

NewsgroupServer
Robot
Robot
Posts: 115623
Joined: 24 Feb 2017, 12:00
Location: World wide

sqlbase 11.02 shutdown

Post by NewsgroupServer » 24 Feb 2009, 16:55

 Posted by:  Rainer Ebert 

Hi Fabrizio,

because we have some problems with deadlocks, I've evaluated some new
features in SB11.0.2. My results are not so good in general. I've made the
experience, that all the new features either do not work (in our case - like
RC in SB11 or SMP in SB11.5 TE) or have bugs. I'm not able to upgrade from
SB9 to 11.0.2 or 11.5 because of the bugs included.

Regarding autolocktable: I would expect more deadlocks and timeouts if
enabling this because always the whole table is locked. Without it, only a
(few) page(s) of the table are locked. So I don't think that it is a good
idea to enable this setting. Especially if you have an application with many
updates/deletes. Enabling the setting for reporting applications with only a
few updates/deletes may be helpful.

Regarding readonly: Note that the default for this has changed from 0 to 1.
So if you don't have this in your sql.ini, it is now 1. If you do not use
the isolation levels RC or RO, setting it to 0 is useful.

Regards,
Rainer

Return to “forum.sqlbase”

Who is online

Users browsing this forum: [Ccbot] and 0 guests