TD3.0 and OLEDB with Oracle 11g

forum.connectivity (1998-2005) & forum.td.connectivity (2005-2010)
Thomas Eberle

TD3.0 and OLEDB with Oracle 11g

Post by Thomas Eberle » 04 Jan 2010, 16:14

 Posted by:  Thomas Eberle 

Hi NG

We r using TD 3.0 and Oracle 9i (9.2.0.5) with OLEDB. It's working since
years with no problem.
Now we like to upgrade to Oracle 11g. But after the migration of de DB we
have encounterd problems reading/writing columns with the datatype LONG.

if i read a LONG Attribute and fetch it into a Long String variable the data
is truncated after 1 Byte.
If i make an insert with a Long String Bind Variable the data in DB after
insert is corrupt (displays only upside-down questionmark).
if i make an insert without bindvariable the data in the db is correct.
So it seems there is a problem with the datatype-conversion or
bind-conversion.

Does anybody have some experiences in this matter?

Thanks for any reply.

P.S.: I tried also to convert LONG in to CLOB. It's the same problem.

Regards
Thomas

Jim McNamara

TD3.0 and OLEDB with Oracle 11g

Post by Jim McNamara » 05 Jan 2010, 14:50

 Posted by:  Jim McNamara 

When we upgraded from 10g to 11g we had some issues that were resoved by
also upgrading the client side to 11g.

Thomas Eberle

TD3.0 and OLEDB with Oracle 11g

Post by Thomas Eberle » 06 Jan 2010, 09:49

 Posted by:  Thomas Eberle 

I did upgrade my Client to 11g, no change in this behavior...

Jim McNamara

TD3.0 and OLEDB with Oracle 11g

Post by Jim McNamara » 06 Jan 2010, 14:36

 Posted by:  Jim McNamara 

We were new to Oracle with 10g. I do know that there were some changes to
handling large objects between 9 and 10. The only help I can offer from
there is to point you to the Oracle support site.

Return to “td.connectivity”

Who is online

Users browsing this forum: [Ccbot] and 1 guest