Upgrading GWD from 3.1 to 2005.1

forum.centura.web.developer (1998-2005) & forum.td.web (2005-2010)
Yannick Fenner

Upgrading GWD from 3.1 to 2005.1

Post by Yannick Fenner » 18 May 2006, 09:55

 Posted by:  Yannick Fenner 

Hi,

I have a server in production which is working fine.

It is in version 3.1 though, and I plan to upgrading the server in the
2005.1 version.

Does anybody here already done that kind of things ? What kind of
recommandations I need to know ?

I'm not sure if I must deinstall GWD3.1 then install GWD2005 from scratch,
or if I must start from GWD3.1 then upgrading it in GWD2005.1...

Thanks for any help,

YF.

Jim McNamara

Upgrading GWD from 3.1 to 2005.1

Post by Jim McNamara » 18 May 2006, 17:05

 Posted by:  Jim McNamara 

The upgrade is pretty transparent and, most always, it's as easy as loading
the outline into the new version and saving it. Sometimes you may have to
update references to external .dll's to the correct version.

Before you migrate:
-Save all outline to text format.
-Back everything up in case you find a show stopper bug and need to
revert to 3.1

Do not uninstall 3.1. 3.1 and 4.1 can coexist on the same PC without
issues. Besides, Gupta's screwy licensing scheme requires that a version
earlier than 4.1 must exist on the PC for a successful installation.

Yannick Fenner

Upgrading GWD from 3.1 to 2005.1

Post by Yannick Fenner » 19 May 2006, 08:23

 Posted by:  Yannick Fenner 

Thanks.

And what about the server ? Once the application is built from GWD2005.1, I
guess I need tu upgrade the web server.

Does the old version need to be deinstalled or is there a direct upgrade
procedure ?

Yannick Fenner

Upgrading GWD from 3.1 to 2005.1

Post by Yannick Fenner » 19 May 2006, 14:35

 Posted by:  Yannick Fenner 

In case it wasn't clear, I was talking about the WAM.

"Besides, Gupta's screwy licensing scheme requires that a version
earlier than 4.1 must exist on the PC for a successful installation"

When you said that, is this true regarding the WAM too ? Any advices ?

Jim McNamara

Upgrading GWD from 3.1 to 2005.1

Post by Jim McNamara » 19 May 2006, 16:29

 Posted by:  Jim McNamara 

I can't help you with the web side of it. We do only client/server apps.

Return to “td.web”

Who is online

Users browsing this forum: [Ccbot] and 0 guests