Deployment Problem with .NET Library and GAILWrapper4.dll

General discussion forum about all things Team Developer 6.x
Chacay
Germany
Posts: 3
Joined: 05 Jul 2017, 15:36
Location: Germany

Deployment Problem with .NET Library and GAILWrapper4.dll

Post by Chacay » 05 Jul 2017, 16:25

TD 6.2 SP5

We have created a .NET DLL (.Net Framework 4.6.1), which we have included in our TD application with the help of the TD .NET Explorer. Especially on the development PC and on some other PCs the application works without any error. On other PCs, while starting the program the application reports following error:

Error...
Error encountered loading library: GAILWrapper4.dll

We have previously run on the PCs "Deploy62.exe" (product version 6.2.5). On those PCs, where the application will run without errors, in the runtime Folder exists the file "GAILWrapper4.dll", while on the other PCs this file is missing. Just copying this file into the program directory does not fix the problem. De- and reinstalling Deplaoy62.exe has no effect.

What can we do to fix this problem?

Many Thanks!

Joachim

Uwe van der Horst
Site Admin
Site Admin
Germany
Posts: 47
Joined: 05 Mar 2017, 14:21
Location: Wetter (Ruhr), Germany

Re: Deployment Problem with .NET Library and GAILWrapper4.dll

Post by Uwe van der Horst » 05 Jul 2017, 18:48

Hi Joachim,

just a guess: We had a similar problem and found out that gailwrapper4.dll needs Gupta.TD.Runtime.System.dll which is not in deployment. You should find it in C:\Program Files (x86)\Gupta\Team Developer 6.2\netbin.

HTH
Best regards,
Uwe van der Horst
Advo-web GmbH

Chacay
Germany
Posts: 3
Joined: 05 Jul 2017, 15:36
Location: Germany

Re: Deployment Problem with .NET Library and GAILWrapper4.dll

Post by Chacay » 06 Jul 2017, 13:16

Hi Uwe,

thanks for your reply. We have copied the Gupta.TD.Runtime.System.dll from ...\netbin into our runtime folder, but the error still happens. Have we to do anything else?

Thanks a lot

Joachim

Christof
Germany
Posts: 8
Joined: 06 Mar 2017, 07:27
Location: Frankfurt, Germany

Re: Deployment Problem with .NET Library and GAILWrapper4.dll

Post by Christof » 07 Jul 2017, 06:18

Possibly .Net 4.6.1 is simply not installed on some of the target machines?

(see: https://docs.microsoft.com/en-us/dotnet ... -installed)

Chacay
Germany
Posts: 3
Joined: 05 Jul 2017, 15:36
Location: Germany

Re: Deployment Problem with .NET Library and GAILWrapper4.dll

Post by Chacay » 10 Jul 2017, 08:54

Hi Christoph,

thank you for your request. On all target PCs we have .Net 4.7 installed. Trying to (re-)install .Net 4.6.1 results in the message: "... already installed."

Any other idea :(? Thanks to all in advance.

Joachim

Return to “General Discussion”

Who is online

Users browsing this forum: Ccbot [Crawler] and 0 guests