Solved Wrong RowFlag behaviour in grid

Discussion forum about all things Team Developer 5.x and 6.x
EwaldP
Austria
Posts: 117
Joined: 07 Mar 2017, 08:00
Location: Austria

Wrong RowFlag behaviour in grid

Post by EwaldP » 18 Jul 2018, 11:12

Hi guys,

the grid reacts wrong on searching rows with SalTblFindNextRow when looking for a special row flag. Opentext created a defect number TD-24114.

TD 6.3 SP2

1. mark 3 rows for delete
2. press delete
3. not all selected rows are marked for delete and are hidden
4. see the difference to behaviour in tablewindow with the same code.

2018-07-17 10_42_59-OpenText Gupta Team Developer 6.3 [Run] - TestCase Grid RowFlags.app - [TestCase.png
2018-07-17 10_43_19-OpenText Gupta Team Developer 6.3 [Run] - TestCase Grid RowFlags.app - [TestCase.png
Please could anybody check if this behaviour also occurs in TD 7.x?

Regards Ewald

TestCase Grid RowFlags.zip
You do not have the required permissions to view the files attached to this post.
Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz
www.edv-hausleitner.at

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 1137
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Wrong RowFlag behaviour in grid

Post by Dave Rabelink » 18 Jul 2018, 11:33

EwaldP wrote:
18 Jul 2018, 11:12
Please could anybody check if this behaviour also occurs in TD 7.x?
Tested on TD7.0.5 and TD 7.1.

Both versions have the same issue.
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

EwaldP
Austria
Posts: 117
Joined: 07 Mar 2017, 08:00
Location: Austria

Wrong RowFlag behaviour in grid

Post by EwaldP » 19 Jul 2018, 07:20

Thanks Dave for testing,

I wonder if anybody could work with the grid (except presenting data). It seems the community keeps faith in MTable.

Ewald
Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz
www.edv-hausleitner.at

Didiman
Germany
Posts: 176
Joined: 21 Mar 2017, 13:05
Location: Bremen, Germany

Wrong RowFlag behaviour in grid

Post by Didiman » 19 Jul 2018, 07:53

Ewald, you're right. Table Window with MTBL is far better than this useless grid. They should implement the MTBL Features in the TD Core and should drop the grid.

Greetz

Andreas

Uwe van der Horst
Site Admin
Site Admin
Germany
Posts: 91
Joined: 05 Mar 2017, 14:21
Location: Wetter (Ruhr), Germany

Wrong RowFlag behaviour in grid

Post by Uwe van der Horst » 19 Jul 2018, 15:07

MTBL is excellent. But in some scenarios we really appreciate the features of the Grids, in particular grouping and saving/loading the grid state.
Best regards,
Uwe van der Horst
Advo-web GmbH

EwaldP
Austria
Posts: 117
Joined: 07 Mar 2017, 08:00
Location: Austria

Re: Wrong RowFlag behaviour in grid

Post by EwaldP » 29 Nov 2018, 07:24

Fixed in 7.1.1
Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz
www.edv-hausleitner.at

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests