Solved Problem: Use loadFromURI with Proxy

Discussion forum about all things Gupta, OpenText and the community.
xenox75
Italy
Posts: 13
Joined: 11 Oct 2018, 14:42
Location: Italy

Problem: Use loadFromURI with Proxy

Post by xenox75 » 28 Nov 2018, 11:12

good morning
how can I use the "loadFromURI" function using the Proxy?
I tried to use "SetProxy" but I do not recognize the function:

I used:
"Set nRetProxy = SetProxy ('10 .2.0.167 ',' 8080 ')"
He returns me:
"Error: Undefined function: SetProxy"

are there any functions to set the proxy to use loadFromURI?
Basically I have to send a link and read the XML data

Thank you
Last edited by xenox75 on 30 Nov 2018, 15:18, edited 1 time in total.

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 2912
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: Problem: Use loadFromURI with Proxy

Post by Dave Rabelink » 29 Nov 2018, 06:04

Personally I dropped to use TD xmllib long time ago due to missing features.
To my knowledge, it still does not support proxies for instance.

Here an old topic about this (from gupta newsgroups):

viewtopic.php?f=58&t=38839


Better use Microsoft XMLHTTP(server).

viewtopic.php?f=27&t=45942
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

xenox75
Italy
Posts: 13
Joined: 11 Oct 2018, 14:42
Location: Italy

Re: Problem: Use loadFromURI with Proxy

Post by xenox75 » 30 Nov 2018, 10:15

I tried:

If I use: MSXML2_XMLHTTP60 does not ask me for the proxy and the link works ...

But I would need to use the proxy to address possible server problems ...

I used MSXML2_ServerXMLHTTP60

my proxy is for example:
IP: "10.0.0.1"
PORT: "3231"

I set:

Call uVariantProxyServer.SetString ("10.0.0.10:3128")
Call uVariantProxyBypasslist.MakeOptional ()
Call uHTTP.setProxy (0, uVariantProxyServer, uVariantProxyBypasslist)

but it does not work, how should I set it?

thanks

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 2912
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: Problem: Use loadFromURI with Proxy

Post by Dave Rabelink » 30 Nov 2018, 13:24

Could you try:

Call uVariantProxyServer.SetString ("http=10.0.0.10:3128")
Call uVariantProxyBypasslist.MakeOptional ()
Call uHTTP.setProxy ( 2, uVariantProxyServer, uVariantProxyBypasslist)

Changes in bold
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

xenox75
Italy
Posts: 13
Joined: 11 Oct 2018, 14:42
Location: Italy

Re: Problem: Use loadFromURI with Proxy

Post by xenox75 » 30 Nov 2018, 14:09

Great, so it works

Thank you, very much ;)

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests