SqlBase 12.0 error

Discussion forum about all things SqlBase.
Posts: 71
Joined: 12 May 2017, 16:07
Location: Kuala Lumpur

SqlBase 12.0 error

Post by chrisocm » 23 Aug 2017, 13:55

I have installed Sqlbase 12.0 (64-bit) on my PC but I have already pre-installed SqlWindows 2.1 which comes with Sqlbase 7.6.1. When I open the Sqlbase 12.0 and Sqltalk 12.0 and I tried to create a database. Creating the database is not a problem. But when I tried to connect to it, the system gives an error

00448 DBA IVD DBS version (<7.5.1>), incompatible with software (<12.0>)

Can anyone help me out here? The problem is there is no 7.5.1.version in the pc.

Posts: 339
Joined: 07 Mar 2017, 08:00
Location: Austria

Re: SqlBase 12.0 error

Post by EwaldP » 24 Aug 2017, 06:27

Do you want to connect with your SQLWindows app or with SQLTalk? Do you have multiple sql.ini files on your system?

In SQLTalk-Menu Help you can see which configuration file is used. Check the entries in the sql.ini

Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz

Igor Ivanovic
Site Admin
Site Admin
Posts: 1365
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

Re: SqlBase 12.0 error

Post by Igor Ivanovic » 29 Aug 2017, 07:53

The error says you are trying to connect to an old .DBS database.
Are you sure you are connecting to a newly created database?
Check for multiple sql.ini files on your system and find out which one sqltalk is using as EwaldP already wrote.

BTW, I am using TD2.1 with SQLBase 12 without problems, but with SQLBase 9 drivers, not the ones that came with TD21.
Igor Ivanovic

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests