Oracle 11g connectivy response time

General discussion forum about all databases other than SqlBase.

Oracle 11g connectivy response time

Post by manimaran » 24 Sep 2013, 11:39


One of our customer using our product developed in CTD 4.2 with Oracle 11g.
Very first time when user try to connect from application it takes around 20 seconds
to connect with database. Once it's connected the database transaction is very fast.

Same thing happens when user connect from SQLTalk also, it takes around 20 seconds.

When user try to connect with database from SQLPlus it takes less than 0ne second.

Please help us to resolve this issue.

Thanks in advance

Posts: 32
Joined: 05 Sep 2018, 11:44
Location: Pfinztal

Re: Oracle 11g connectivy response time

Post by ZERO_JB » 26 Sep 2013, 08:56


At some customers infrastructures we did get this also. We solved it by changing some parameters in the "sqlnet.ora" - You will locate this file in the Oracle client directory section under ..\network\admin\, if not you have to generate one.
Our entries are:


The connection should be much faster now, because of the kind of searching the oracle host.

This is only usable if you use the full client version, the instant client also have some problems, why we did not use it.

Best Regards

Joerg Bertram


Re: Oracle 11g connectivy response time

Post by manimaran » 27 Sep 2013, 09:10

Hi Joerg,

Thanks for your valuable information. I tried your inputs, but no change in connectivity response time.
It is very slow.


Posts: 17
Joined: 23 Mar 2017, 17:04
Location: Paris, France

Re: Oracle 11g connectivy response time

Post by coolatsa » 30 Sep 2013, 18:04


what is the version of Oracle on client side ?

what is the connection time with sqlplus ?

We had an issue with Oracle client 11g or 12c against a 10g Oracle Database.
We try Instant client 10g which give a better connection time than the Oracle 11g client :
from 5 seconds (Oracle client 11g or 12c) to 1 seconds (Oracle client 10g) for the first SqlConnect function.

Our application is in TD 4.1 (old version) and TD 6.1 (new version) but the problem is more "visible" on TD6.1



Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests