Stored procedure stops after few seconds.

General discussion forum about all databases other than SqlBase.
chris@kresoft
Belgium
Posts: 10
Joined: 03 May 2017, 07:22
Location: Belgium

Stored procedure stops after few seconds.

Post by chris@kresoft » 20 Aug 2013, 14:18

Hi,

I have a problem with executing a stored procedure in TD6.1. The database I use, is Sql Server 2008 R2. I use the function 'OdrExecuteProc' to run the SP.
The SP makes a copy of lines from one table to another. In the SP a second SP is started that makes a copy of the details of the line copied in the first SP.
The SP starts, but there are only a few lines copied. It seems like it just stops after a few seconds. When I delete some of the detail lines, there are more lines from the first table copied. So it looks like the stored procedure runs for a time and copies some lines and just stops. I would expect that when the SP can not be run completely that there should be a rollback. But that isn't the case. I have soms lines that are copied with the details.
The SP runs without any problem in the management studio so there is nothing wrong with the SP itself.
Can anybody tell me how I can make the time to runs the stored procedure from TD 6.1 longer?

Thanks,
Chris

chris@kresoft
Belgium
Posts: 10
Joined: 03 May 2017, 07:22
Location: Belgium

Re: Stored procedure stops after few seconds.

Post by chris@kresoft » 22 Aug 2013, 15:15

Hi,

When I use ole db to connect to the sql server database the stored procedure works fine. But when I connect at the start of the application with odbc, I can't make a ole db session at the moment when I want to execute the SP. Does anyone knows if this is a know problem or if I have to do something before making a ole db session when there is already a connection using odbc.

Thanks,
Chris

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests