Solved TD-23777: Oracle DBP_LONGBUFFER not working in 6.3.9

Report TD 5.x and 6.x bugs and possible workarounds.
Posts: 53
Joined: 03 May 2017, 08:00
Location: Finland

TD-23777: Oracle DBP_LONGBUFFER not working in 6.3.9

Post by -tommi » 21 Dec 2017, 15:32


We fetch BLOB-data from Oracle with DBP_LONGBUFFER etc. parameters.
It was working in 6.3. Update 1R, but after upgrading to 6.3.9 it is not working anymore.
All data is truncated at around 64k.

We have the usual settings for binary fetch:

Code: Select all

--At the beginning:
Call SqlSetParameterAll ( hSql, DBP_ORAUSELOB, TRUE, '', TRUE )
Call SqlSetParameterAll ( hSql, DBP_LONGBUFFER, 32*1024*1024, '', TRUE )
---and before execute:
Call SqlSetLongBindDatatype( 1, 23 )
I have tried with different Oracle Clients, but the TD-version seems to be the problem here.
Any ideas?

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Posts: 3384
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: TD-23777: Oracle DBP_LONGBUFFER not working in 6.3.9

Post by Dave Rabelink » 21 Dec 2017, 17:16

Already reported.
Read this :

Dave Rabelink

Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests