SQLBase 11.5 Stored Procedure Woes

Report SqlBase bugs and possible workarounds.
Clifford Bass

SQLBase 11.5 Stored Procedure Woes

Post by Clifford Bass » 16 Apr 2010, 21:34

Hi,

SQLBase 11.5.0 SP3 Treasury on Windows XP SP3. Using fully patched Access 2007 with SP2 and ADODB and Unify SQLBase ODBC driver or the OLEDB provider.

I am no longer able to execute stored procedures/commands that require parameters. These worked fine using the 11.0.2 SP1 client files. Now with 11.5.0 they either return an error if using the ODBC driver, or crash Access if using SQLBASEOLEDB.

Out of curiosity I also did some tests in VB .NET and encountered some issues there, both with the 11.5.0 client files and with the 11.0.2 client files. One test machine has Access 2007 and only SQLBase 11.5.0 SP3 The other machine has Access 2003 and 11.0.2 SP1. Please note that I am stuck at SP1 on the second machine as subsequent service packs caused other client program issues for me.

Attached is an Access database file that can be used to demonstrate the problems. Also there are two VB files that can be added to a Visual Basic .NET project to demonstrate the problems I encountered there. Essentially the same code is used to do the testing in both Access (mdlStoredProcedures) and VB (StoredProcedures.vb). There are some instructions at the beginning of the "StoredProcedures.vb" file for settings needed in the VB project. Make the form your startup object. These all access the Island database. Each button attempts to use a specific driver/provider in order to store a simple select command and then to execute it.

Questions, please let me know.

Sincerely,

Clifford Bass
You do not have the required permissions to view the files attached to this post.

Mike Vandine

Re: SQLBase 11.5 Stored Procedure Woes

Post by Mike Vandine » 19 Apr 2010, 04:54

Hi Cliff,

You sure are keeping me busy! :)

Thanks for the report. I will check it out and get back to you.

Best regards,

Mike

Clifford Bass

Re: SQLBase 11.5 Stored Procedure Woes

Post by Clifford Bass » 19 Apr 2010, 17:49

Hi Mike,

Consider it job-security :-) !

I almost hate to say this but I have another issue that I plan to report soon that has to do with outer joins in Access via ODBC. I just need to figure out a test case for you.

Clifford

Mike Vandine

Re: SQLBase 11.5 Stored Procedure Woes

Post by Mike Vandine » 24 Jun 2010, 05:36

Hi Cliff,

I've created defect SQLB-1361 for this issue.

Cheers!

Mike

Clifford Bass

Re: SQLBase 11.5 Stored Procedure Woes

Post by Clifford Bass » 24 Jun 2010, 17:12

Hi Mike,

Thanks here too!

Cliff

joergm

Re: SQLBase 11.5 Stored Procedure Woes

Post by joergm » 16 Mar 2011, 11:15

Hi all,

I found this, searching for solution for my problem:
Since update from SQLBase 8.1.0 to 11.5. I'm not able to call stored procedures with parameters any more.
The concerning software ist written in VB an is working with ODBC.

Is there already a patch for SQLB-1361 ?
Yesterday I installed SP4 but 1361 is not mentioned and it still didn't run.

Is there another workaround to solve the problem ?

Thanks for your efforts

Joerg

Clifford Bass

Re: SQLBase 11.5 Stored Procedure Woes

Post by Clifford Bass » 16 Mar 2011, 17:21

Hi Joerg,

I have been working with Mike and the Unify engineers on these issues. I believe most of the problems are solved in the 11.6 drivers. But not all. Last I heard, they expect to release a fixed driver pack sometime in the near future. The fixes they are making are designed to work with earlier versions so it should work with 11.5. Because of a large variety of issues, they may or may not provide patches to the older drivers. Mike can correct me on any misinformation.

Clifford

Mike Vandine

Re: SQLBase 11.5 Stored Procedure Woes

Post by Mike Vandine » 17 Mar 2011, 04:18

Hi Cliff,

Correct. 11.6 SP1 will be released shortly that should fix these issues. After this release, we will be working on the Driver Pack release, a stand-alone release of all the connectivity drivers. However, the fixes will be in the SP1 release and can be used with the 11.5 version as well.

Best regards,

Mike

Return to “SqlBase Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 1 guest