Migration of LONG NVARCHAR to SB11.6

Report SqlBase bugs and possible workarounds.
User avatar
Peter.Hugk
Germany
Posts: 340
Joined: 06 Mar 2017, 07:48
Location: Germany

Migration of LONG NVARCHAR to SB11.6

Post by Peter.Hugk » 09 May 2011, 09:12

I was unable to migrate LONG NVARCHAR columns of SB 10 to 11.6. Using the migration wizard I get only "?" per Chinese character. And doing an unload in SQLBase 10 doesn't work either because the format is (at least partly) incompatible with SQLBase 11.6.
How is it expected to work?

Attached you will find a "real life" example of a table to migrate. Please load this to an empty SQLBase 10 database and try to migrate to SQLBase 11.6. I do not want to change column types and of course need all content unchanged also.
You do not have the required permissions to view the files attached to this post.

Mike Vandine

Re: Migration of LONG NVARCHAR to SB11.6

Post by Mike Vandine » 11 May 2011, 10:18

Hi Peter,

I will try to get to this tomorrow.

Best regards,

Mike

Mike Vandine

Re: Migration of LONG NVARCHAR to SB11.6

Post by Mike Vandine » 11 May 2011, 10:19

BTW, did you try this using 11.6 SP1 or the production release? I know there were many changes done to the migration wizard between these releases.

Also, can you do this successfully using SQLTalk with an unload from 10 and a load to 11.6?

User avatar
Peter.Hugk
Germany
Posts: 340
Joined: 06 Mar 2017, 07:48
Location: Germany

Re: Migration of LONG NVARCHAR to SB11.6

Post by Peter.Hugk » 11 May 2011, 13:00

I did this with 11.6 SP1. I Never had the production release installed.

No, I can't. As I wrote, and you may test that with the attached sample, 11.6 can not load my table unloaded from 10.

Mike Vandine

Re: Migration of LONG NVARCHAR to SB11.6

Post by Mike Vandine » 12 May 2011, 07:03

Hi Peter,

Yes, I can reproduce this problem!

When the conversion is done, the longnchr columns defined on the SB10 version are converted to longvar on the 11.6 database. Thus, when a double-byte character like Chinese or Japanese is put into the column it is then unreadable.

I also tried to leave the checkbox (convert to nchar, etc.) ticked and got the same results.

I will log a defect.

Best regards,

Mike

Mike Vandine

Re: Migration of LONG NVARCHAR to SB11.6

Post by Mike Vandine » 12 May 2011, 07:19

Hi Peter,

I have created defect SQLB-1621 for this issue.

Best regards,

Mike Vandine

Re: Migration of LONG NVARCHAR to SB11.6

Post by Mike Vandine » 19 May 2011, 08:48

Hi Peter,

This defect has been fixed and will be available in the 11.6 SP2 release.

Best regards,

Mike

User avatar
Peter.Hugk
Germany
Posts: 340
Joined: 06 Mar 2017, 07:48
Location: Germany

Re: Migration of LONG NVARCHAR to SB11.6

Post by Peter.Hugk » 19 May 2011, 15:54

Which will be available when?

Mike Vandine

Re: Migration of LONG NVARCHAR to SB11.6

Post by Mike Vandine » 19 May 2011, 16:04

Hi Peter,

Please contact me privately: mike.vandine@guptatechnologies.com

Return to “SqlBase Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests