Snapshot Backup

Report SqlBase bugs and possible workarounds.
Mike Vandine

Snapshot Backup

Post by Mike Vandine » 29 Jan 2016, 02:39

Hi Mauro,

>>Are you trying to do a segmented backup?
How big is your database?<<

Any answers to these questions? As you know, segmented processing has been discontinued for SB12.

That is truly bizarre.

>>we try to launch a Query the results is that the db crash and the table involved in our query Table is corrupted.<<

Clarifications please:

1. If there are no queries done, does the backup snapshot work?
2. What error do you get from the query that indicates that the table is corrupted?
3. Do you get that error and then the SQLBase server *engine* crashes, i.e. the whole SQLBase engine stops, not just the one database?

Can you try turning logbackup on for the database and doing a 'backup database', the 'release log' and 'backup logs'? Does that produce the same crash? If you are only doing backup snapshots, you are at great risk of losing data. See a whitepaper on setting up correct backup/recovery procedures so you have maximum recovery options.

http://support.guptatechnologies.com/su ... ite_Papers

Grab the second paper under the Previouos Versions' heading.

What we *really* need is a reproducible testcase. If we can reproduce it, we can fix it!

Best regards,

Plasti

Snapshot Backup

Post by Plasti » 01 Feb 2016, 09:25

Dear Mike,

no, we are trying to create a normal snapshot backup, we also tried to create a segmented backup but without success.
1. Without Queries the snapshot work
2. If we launch a query during the backup DataBase we receive an error that say that the index in the table involved is corrupted. (Error 850, row LRP check Failure, DataPage corrupted).

We launch a Backup with logbackup on. Same problem.

We have a Dump of the crash (*****972.dmp is with segmentation, the other one is without segmentation) , is here attached.
You do not have the required permissions to view the files attached to this post.

Mike Vandine

Snapshot Backup

Post by Mike Vandine » 02 Feb 2016, 05:29

I've done some testing on this (thanks, Fabio)!

Here are my findings.

1. I created a 5.0 GB database with two tables, each having 5 million rows, connecting with TCP/IP.
2. Tried various settings in the sql.ini file
a. cache=64000 to cache=512000
b. readonly=0 with RL or RR isolation levels in SQLTalk
c. readonly=1 with RC3 isolation level in SQLTalk
3. Tried different forms of backups
a. Backup snapshot (on server and on client) with the ‘from dbname’ option
b. Connect to database and backup snapshot without the ‘from dbname’ option
c. Backup database, release logs, backup logs

Regardless of all these variations, I could produce a hang of a SQLTalk session (but not a crash). Here are the statements:

SQLTalk session 1:

set server sb1232;
backup snapshot from sb12test to c:\backups on server;

SQLTalk session 2:

connect sb12test;
select * from systables;
select count(*) from caps_detail;

The select * from systables works fine, but the select count(*) hangs. The first session reports ‘Snapshot Backed Up’ and I can drop that session, but the second session runs forever with 100% CPU.

BTW, I had to be quick to get to the second session. The backup snapshot of a 5GB database only takes around 40 seconds.

I have given all this information to Development and they will be able to reproduce it, I am sure. If they can reproduce it, they can fix it!!

I will keep you all posted on our findings and when we get a fix I will make it available to you.

Best regards,

Mike Vandine

Snapshot Backup

Post by Mike Vandine » 05 Feb 2016, 01:54

Hi all,

Just FYI, this has been assigned defect number SQLB-2461 and Development are hot on the trail of getting it squashed.

I will keep you informed when we get a fix.

Best regards,

Mike

Plasti

Snapshot Backup

Post by Plasti » 05 Feb 2016, 13:54

Thanks Mike, hope to receive news soon :-)

Cheers

Mike Vandine

Snapshot Backup

Post by Mike Vandine » 08 Feb 2016, 03:43

Hi all,

I have a fix for this. If you would like to try it out, please contact me privately and I will give you the URL for the patch.

Best regards,

Plasti

Snapshot Backup

Post by Plasti » 09 Feb 2016, 17:28

Ddear Mike,

thanks, we can confirm that the FIX that you sent us, solved our problem.

Thanks again
Mauro

Mike Vandine

Snapshot Backup

Post by Mike Vandine » 09 Feb 2016, 23:08

Thanks for the confirmation!!

EwaldP
Austria
Posts: 370
Joined: 07 Mar 2017, 08:00
Location: Austria

Snapshot Backup

Post by EwaldP » 25 Feb 2016, 09:33

Hi Mike,

I think I have a similar problem. The last 2 days database crashed at the same time as the backup should started. Fail.sql is enclosed. Today in the morning Command Center shows the status of the backup (snapshot) job as "executing", but no action. Only the BKP-file was copied, no log-file. So I have no current backup to check if the database is corrupted because I can't force the users to logout. I will try to get a copy from database today at lunchtime but as I read the forum threads I assume that the problem is not a corrupted database.

Thanks in advance

Best Regards
Ewald
fail.sql
You do not have the required permissions to view the files attached to this post.
Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz
www.edv-hausleitner.at

Mike Vandine

Snapshot Backup

Post by Mike Vandine » 25 Feb 2016, 09:57

Hi Ewald,

Please let me know privately if you want the fix. Reference this thread in the email and 'EMP120.3'.

Best regards,

Mike

phil@informasys.com

Snapshot Backup

Post by phil@informasys.com » 09 Apr 2016, 15:49

This is reported as Fixed in 12.0.1 (see: SQLBase 12 Service Pack 1 (SP1) is now available :https://support.guptatechnologies.com/s ... 22&t=12654
[SQLB-2461] - Executing a BACKUP SNAPSHOT causes crash/hang/corruption.

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests