Solved TD-3949: SqlPLSQLCommand after SP2

Post found bugs and possible workarounds.
Suehart

TD-3949: SqlPLSQLCommand after SP2

Post by Suehart » 09 Apr 2008, 08:57

Hi,

I have loaded TD5.1 SP2 and recompiled my application and started to re-test. During testing I have found that the SqlPLSQLCommand continues not to work. :(
According to the patchset list this issue has been resolved TD-4111. The error message is as before : When running the code I get an Oracle error ora-04043 unable to find object. It says that hh_get_file does not exist.

This is stopping the project from progressing and is becoming a worry for the client. I do not want to have to re-write code using different commands when this issue should have been fixed by the patchset.

Please can you advise why it is still an issue.

caa

Re: TD-3949: SqlPLSQLCommand after SP2

Post by caa » 09 Apr 2008, 14:02

Suehart,

If we've marked the defect as closed, it's because the repro case that we had is resolved. If it's not resolved for you, then please send us the non-working repro case so that we can test it here.

-tommi
Finland
Posts: 53
Joined: 03 May 2017, 08:00
Location: Finland

Re: TD-3949: SqlPLSQLCommand after SP2

Post by -tommi » 10 Apr 2008, 07:17

Hi.

Is there any one who is using SqlPLSQLCommand with SP2 and Oracle native router?
If so, then what is you Oracle version and NLS-settings?

We have tried a few different cases and not a single one has worked. Result is always either ORA-04043 or ORA-24323.

-tommi

johi

Re: TD-3949: SqlPLSQLCommand after SP2

Post by johi » 10 Apr 2008, 08:19

Here is my repro case with native Oracle router, very simple: SqlConnect, followed by a SqlPLSQLCommand with a standard Oracle PLSQL call.

client NLS_LANG is set to AMERICAN_AMERICA.AL32UTF8, setting a single byte codepage did not help.
(NLS_LANG=AMERICAN_AMERICA.WE8MSWIN1252).
Anyway, the release notes state that NLS_LANG encoding has to be set to UTF-8, it makes no sense to restrict Oracle client to a single byte codepage!

Jean-Marc Gemperle

Re: TD-3949: SqlPLSQLCommand after SP2

Post by Jean-Marc Gemperle » 10 Apr 2008, 14:09

Hi Sue,

I know you meant

TD-3949
ORACLE: SqlPLSQLCommand returns errors ORA-04043 and ORA-24323 when SP executed is not in the same schema

And not TD-4111 that is a crash invoking a SP using SqlPLSQL without any oracle error returned (FIXED IN SP2)

this thread
contains the TESTCASE that used to reproduce the error and to enter the bug. Testing on my environment it no longer returns the error, can you test this reprocase on your env. If it does not fail, can you adapt it to show us the ORA-04043 error

Thanks
JM

remi1@hotmail.com
Peru
Posts: 30
Joined: 04 Apr 2017, 16:31
Location: Lima, Peru

Re: TD-3949: SqlPLSQLCommand after SP2

Post by remi1@hotmail.com » 19 Apr 2008, 01:15

Hello Everybody :

I just read that you guys where working in this problem before me. My migration has been stoped.
I have like 1200 SqlPlSqlCommand in my application each one explote the database (oracle 10g r2) perfectly.

I'm runnign
Windows Vista Bussiness in Spanish with sp1
TD 5.1 SP2
Oracle 10g r2

regard
Remi
You do not have the required permissions to view the files attached to this post.

icekiz

Re: TD-3949: SqlPLSQLCommand after SP2

Post by icekiz » 21 May 2008, 03:47

Hi

I am having simillar problem with SqlPLSqlCommand TD5.1 SP2.

Is this will be fixed next SP or need to be updated with new command?
Updating command will take a lot of hours to fix and testing. So that option is not that attractive to us.


Paul Lee :roll:

caa

Re: TD-3949: SqlPLSQLCommand after SP2

Post by caa » 21 May 2008, 13:48

The repro case that we received is fixed in the next service pack.

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests