Solved Connection to postgres 9.6 fails with TD 6.3.9 but works with SQLTalk

Post found bugs and possible workarounds.
Johann
Austria
Posts: 369
Joined: 30 Mar 2017, 09:58
Location: Vienna

Connection to postgres 9.6 fails with TD 6.3.9 but works with SQLTalk

Post by Johann » 18 Nov 2021, 12:45

Hello,

I face a strange problem with TD 6.3.9 on Postgres 9.6, connecting with SQLTalk (from TD 6.3.9) no problem, I can connect, create tables, constraints, select, insert, update, delete... works normally without any issue, but when trying to connect with the td 6.3.9 application I get the following error

PostgreSQL error: Fatal: role "username" does not exist

but actually the role exist, and I can use it normal with SQLTalk.

The odbc driver for Postgres is V. 13.02.00.00 PostgreSQL ANSI. I tried also the PostgreSQL UNICODE, but no change, SQLTalk works, TD gets the above error.

Any hint is very appreciated.
With best Regards
Johann

Harald
Germany
Posts: 168
Joined: 30 Mar 2017, 06:16
Location: Rosenheim, Germany

Re: Connection to postgres 9.6 fails with TD 6.3.9 but works with SQLTalk

Post by Harald » 18 Nov 2021, 17:37

Hello Johann,

did you try to change username and password to uppercase and lowercase on server and client?

Kind regards
Harald

Johann
Austria
Posts: 369
Joined: 30 Mar 2017, 09:58
Location: Vienna

Re: Connection to postgres 9.6 fails with TD 6.3.9 but works with SQLTalk

Post by Johann » 19 Nov 2021, 12:46

Hello Harald,

yesssss :) this was it..... THX

Regrds
Johann

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 1 guest