Problem with SalReportView() command in TD 5.1

Discussion forum about all things Report Builder (all versions).
esal

Problem with SalReportView() command in TD 5.1

Post by esal » 28 Jan 2009, 13:10

In 5.1, the application shuts down abnormally when calling this function (SalReportView). Please see code below:

If Not SalReportView( hWndForm, hWndNULL, 'ppr.qrp',
':sReportPageHeader, :SqlUser, :sReportText',
'sReportPageHeader, sRequestedBy, sReportText', nError )
Call fWaitCursor( FALSE )
Return FALSE

So what I did was I opened the QRP File (ver. 4.2) via ReportBuilder 5.1 and saved it to convert to 5.1. This didn't fix the problem. But when I was inside the ReportBuilder IDE, I was able to execute the Print Preview option (with dummy data displayed of course). Please advise on what I need to do here.

Jeff Luther

Re: Problem with SalReportView() command in TD 5.1

Post by Jeff Luther » 28 Jan 2009, 13:23

Please advise on what I need to do here
Submit this issue to the Bug Reports section and attach a zip of the v4.2 QRP file and the v5.1 version of the file.

(I will assume you did not overwrite your 4.2 file when you saved out in 5.1. If you did, I would suggest getting your backup of the 4.2 file and saving out with RB 5.1 to a different file name and trying your test again, with the new ppr name like 'ppr-v51.qrp'. )

You have installed 5.1 SP4, right?

esal

Re: Problem with SalReportView() command in TD 5.1

Post by esal » 28 Jan 2009, 14:29

Jeff Luther wrote:
Please advise on what I need to do here
Submit this issue to the Bug Reports section and attach a zip of the v4.2 QRP file and the v5.1 version of the file.

(I will assume you did not overwrite your 4.2 file when you saved out in 5.1. If you did, I would suggest getting your backup of the 4.2 file and saving out with RB 5.1 to a different file name and trying your test again, with the new ppr name like 'ppr-v51.qrp'. )

You have installed 5.1 SP4, right?
Yes I did overlay the 4.2 file when I saved it within RB 5.1. Not sure if saving the file to a different name would help but I will try. Yes I did install 5.1 SP4. I will attach the PPR.QRP file to the Bugs section as well. Thanks for your response.

esal

Re: Problem with SalReportView() command in TD 5.1

Post by esal » 28 Jan 2009, 14:38

Hi,

Please see attached zip file. By the way, I saved the PPR.QRP file (ver. 4.2) to a different filename using Report Builder 5.1 and didn't fix the problem.

Thanks for looking into this.
You do not have the required permissions to view the files attached to this post.

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 1 guest