Report Writer 5.2 and SQL.INI file

Discussion forum about all things Report Builder (all versions).
h.steinmann

Report Writer 5.2 and SQL.INI file

Post by h.steinmann » 08 Oct 2010, 07:20

Hallo,

I'm working with TD 5.2 SP2. I have one Sql.ini file which is in a special directory x:\user.
Therefore I take this path in TD under tools - preferences - General as Sql.ini-File Path.
This works perfect all the years. But when I started the report-writer, it needs the sql.ini in the
programm directroy of TD. WHY????? Why does'nt it take the path which stands under preferences?

What I can I do? I don't wan't to have the file in the programm directory.
Thanks in advance.

Jeff Luther

Re: Report Writer 5.2 and SQL.INI file

Post by Jeff Luther » 08 Oct 2010, 22:02

when I started the report-writer (ReportBuilder - RB?), it needs the sql.ini in the programm directroy of TD. WHY?????
Likely because it needs the INI file since RB can connect to your DBs and needs the INI settings for that.

You have 'cheated' a bit with TD: you can override, or special-case, what folders you want TD to use and look in. That's why x:\user has worked for you with TD, I guess.

RB has no such 'short-cut' places; It's going to need SQL.INI and will use the standard Windows PATHs to find the first one in the PATH.
Why does'nt it [RB] take the path which stands under preferences?
Because that's special for TD only, not RB. RB doesn't know about the TD Preferences.

SOLUTION: You will need to make sure your PATH settings are correct for the SQL.INI RB needs when it launches.

anuta

Re: Report Writer 5.2 and SQL.INI file

Post by anuta » 11 Oct 2010, 08:33

You can change the path in the Registry as desired.

To do this, you can rename extension of the attached file from txt to reg and then double click on it to make the corresponding registry setting.

File content is simply the text:

[HKEY_CURRENT_USER\Software\Gupta\ReportBuilder 3.1\Settings]
"INIFilePath"="x:\\user\\sql.ini"

Greetings
Anna

anuta

Re: Report Writer 5.2 and SQL.INI file

Post by anuta » 11 Oct 2010, 08:40

The previos posting is for RB31, for RB 52 use:

[HKEY_CURRENT_USER\Software\Unify\ReportBuilder 5.2\Settings]
"INIFilePath"="x:\\user\\sql.ini"

h.steinmann

Re: Report Writer 5.2 and SQL.INI file

Post by h.steinmann » 11 Oct 2010, 10:36

Hallo Anna,

thanks for quick help. I've done it and it works perfectly.

Thanks again.

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 1 guest