Problem save report as pdf

Discussion forum about all things Report Builder (all versions).
EwaldP
Austria
Posts: 351
Joined: 07 Mar 2017, 08:00
Location: Austria

Problem save report as pdf

Post by EwaldP » 28 Feb 2023, 13:52

Hi guys,

since a couple of weeks one of our customer has a problem with save report as pdf. After SalReportPrintToFile (as pdf) the generated pdf can't be open. Adobe Reader says that the file is corrupt. This error happens only after 12 pm. After a restart of the machine everything works fine. We searched in the eventprotocol, no service is running at 12.00, can't figure out the problem.

Maybe a wrong dll in the memory?
Tomorrow we will try without the anti-virus software.

Other suggestions?

Thanks in advance
Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz
www.edv-hausleitner.at

Uwe van der Horst
Site Admin
Site Admin
Germany
Posts: 594
Joined: 05 Mar 2017, 14:21
Location: Wetter (Ruhr), Germany

Re: Problem save report as pdf

Post by Uwe van der Horst » 28 Feb 2023, 13:59

Did you check if the generated PDFs are empty (0 KB)? Is the target directory a network drive?

viewtopic.php?f=28&t=73629&p=240232&hil ... rk#p240232
Best regards,
Uwe van der Horst
Advo-web GmbH

EwaldP
Austria
Posts: 351
Joined: 07 Mar 2017, 08:00
Location: Austria

Re: Problem save report as pdf

Post by EwaldP » 02 Mar 2023, 07:00

Hi Uwe,

yes I already checked (my first task was to check the threads here in the forum :) ). Same behaviour on local or network drive. File has 0 KB.
Ewald P. Palmetshofer
EDV-Hausleitner GmbH
4020 Linz
www.edv-hausleitner.at

User avatar
Charlie
Canada
Posts: 640
Joined: 07 Mar 2017, 18:52
Location: Fredericton, New Brunswick, Canada

Re: Problem save report as pdf

Post by Charlie » 21 Mar 2023, 12:57

EwaldP wrote:
28 Feb 2023, 13:52
Hi guys,

since a couple of weeks one of our customer has a problem with save report as pdf. After SalReportPrintToFile (as pdf) the generated pdf can't be open. Adobe Reader says that the file is corrupt. This error happens only after 12 pm. After a restart of the machine everything works fine. We searched in the eventprotocol, no service is running at 12.00, can't figure out the problem.

Maybe a wrong dll in the memory?
Tomorrow we will try without the anti-virus software.

Other suggestions?

Thanks in advance
Silly questions...

The error only happens after 12pm, but is there a time (say 2pm or whatever) after which there are no more errors ?

Or is it a situation in which all print to PDF attempts at and after 12pm have the error, and a reboot is required to have no more errors again until 12pm the next day?

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests