Solved TD-14641: Report Builder Format Problem

Report bugs and possible workarounds.
ivano_osti
Brazil
Posts: 415
Joined: 17 Nov 2017, 20:02
Location: Itapira-SP, Brazil

TD-14641: Report Builder Format Problem

Post by ivano_osti » 23 Dec 2010, 15:30

Hi.

We use in Brazil "." as thousand separator and "," as decimal separator. Ex: 1.500,00

If I start a brand new QRP I cannot set "#.##0,00" as format for a number input variable. See:
FormatValidationError.JPG
If I save in TD60 a QRP made with CTD151, it works fine. See:
FormatSetFromCTD151.JPG
Preview.JPG
Is that a bug?

One of my team mates made a brand new QRP with TD60 and she is not able to use this format... Is there a workaround?

Thank you.
You do not have the required permissions to view the files attached to this post.

Jeff Luther

Re: TD-14641: Report Builder Format Problem

Post by Jeff Luther » 28 Dec 2010, 01:56

I've entered this as TD/RB defect TD-14641.

"Workaround?" -- Unfortunately, in RB I do not know of one. Not for directly in RB itself.

Kluge workaround: If your data are coming from a TD appl, you could set the Number input item field to a String, then format the number 'string' value to be the correct format. Something like this, for example:
* fetch a number from the DB into a string var, like "12345.67" (or fetch into a number variable, then convert to a string)
* parse/format the string so it looks like: "12.345,67"
* now send that string value to the report when SAM_ReportFetchNext does a Return TRUE

All the code conversion can be done in SAM_ReportFetchNext before the Return TRUE statement. NOTE, this could be a lot of work if you have lots of decimal numbers, so I am only suggesting this if you must have numbers look like "12.345,67".

Jeff Luther

Re: TD-14641: Report Builder Format Problem

Post by Jeff Luther » 28 Dec 2010, 23:56

Ivano: Better news! Ignore my workaround suggestion in the previous msg.

I found out that using "International setting" is in RB itself. Here's how to get "#.##0,00" as a number format in your report:

* have your Windows regional setting like Portuguese/Brazil
* Open the CQT/QRP file
* Go to design mode
* anywhere in 'white space' outside any section, r-click and click Properties... (or use Alt+Enter) - this is the properties section for the entire report itself
* right side of the dlg. box is a checkbox called "Enable Intl Number Display"
* check/click that, then click OK
* now, you have to save the report, close RB and reopen the report. (This is now the defect for TD-14641 and will get fixed)
* When the report is reopened, in design mode r-click on a number-type item and r-click, then Properties. It should be formatted as "#.##0,00". If not, you should be able to add that format.

ivano_osti
Brazil
Posts: 415
Joined: 17 Nov 2017, 20:02
Location: Itapira-SP, Brazil

Re: TD-14641: Report Builder Format Problem

Post by ivano_osti » 29 Dec 2010, 18:22

Hi my friend.

It worked with your workaround.

Thank you.

Jeff Luther

Re: TD-14641: Report Builder Format Problem

Post by Jeff Luther » 29 Dec 2010, 20:40

Glad to hear it! Thanks for letting us know.

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests