Solved TD-15736: RB: Copy and Paste does not work with RichText-fields

Report bugs and possible workarounds.
Georg Diczig
Germany
Posts: 175
Joined: 15 Mar 2017, 15:15
Location: Cologne Germany

TD-15736: RB: Copy and Paste does not work with RichText-fields

Post by Georg Diczig » 08 Jun 2011, 12:11

Copy and Paste does not work with RichText-fields.
Copying a RichText-field RB insert a normal field without contect.
Copying a line with a RichText-field RB ask "item is not created. Do you want to create this item?".
If I answer with yes RB create the new line but the RichText-field is not created correctly.

See the video at:
https://www.softwarepartner.com/fileadmi ... yPaste.swf
See also the attached qrp-file.


RepBi60.exe
SP2 EMP5347
Fileversion 6.0.2.25118
You do not have the required permissions to view the files attached to this post.
Best Regards
Georg Diczig

Jeff Luther

Re: TD-15736: RB: Copy and Paste does not work with RichText-fields

Post by Jeff Luther » 08 Jun 2011, 19:39

Video helped me understand your issue, Georg. Good idea!

Yes, I see this: Ctrl+c then +v copy/pastes the other fields like string and number, but not RT.

Note, though, that RT is special-cased. Try this:
* add a new Field item to a line
* Select it and drop down Content.
* Note that RT is not listed -- it has it's own toolbar object, like graph, crosstab, etc.
* I see, though, that graph, box, etc. can be copied.

It Appears to be a bug that a RT object cannot be copy/pasted. I have added RB defect TD-15736 for this problem.

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests