TD-20485: Rep.Builder - Problem when displaying to an own window (WPF)

Report bugs and possible workarounds.
ivano_osti
Brazil
Posts: 415
Joined: 17 Nov 2017, 20:02
Location: Itapira-SP, Brazil

TD-20485: Rep.Builder - Problem when displaying to an own window (WPF)

Post by ivano_osti » 03 Dec 2013, 18:25

Hi.

If I use a modal dialog to call a SalReportView( hWndFrm, hWndRptTemp, strTemplate, strVariables, strInputs, nFlags ) with the 2nd parameter as hWndNULL, I have problems in WPF mode.

The problem is that the window that is displaying the report (hWndRptTemp) stays behind the dialog, avoiding me to click any button. Ex: Next page...

See the problem:
RB_Display_WPF.JPG
I'll just be enabled to click the buttons after I close de dialog. I must not do this because if I close the dialog I no more have SAM_ReportFetchNext...

In WIN32 mode, I don't have this problem because hWndRptTemp is on top. See:
RB_Display_WIN32.JPG
Thank you.
You do not have the required permissions to view the files attached to this post.

VEspinal

Re: TD-20485: Rep.Builder - Problem when displaying to an own window (WPF)

Post by VEspinal » 06 Dec 2013, 12:57

Hi Ivano:

Can you please send a reprocase (.apt) along with the RB (.rpt)?

Thanks in adance.

Regards,
Victor Espinal

ivano_osti
Brazil
Posts: 415
Joined: 17 Nov 2017, 20:02
Location: Itapira-SP, Brazil

Re: TD-20485: Rep.Builder - Problem when displaying to an own window (WPF)

Post by ivano_osti » 06 Dec 2013, 15:13

Hi Victor.

Reprocase attached using SQLBase/Island.

Thank you.
You do not have the required permissions to view the files attached to this post.

VEspinal

Re: TD-20485: Rep.Builder - Problem when displaying to an own window (WPF)

Post by VEspinal » 10 Dec 2013, 00:40

Hi Ivano:

Just to inform you that I was able to reproduce the issue and logged a defect TD-20485

We will keep you informed on any news.

Thanks for the information.

Regards.
Victor

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests