Solved TD-22595: Reportbuiler page not visible with page header contionned

Report bugs and possible workarounds.
bcotting

TD-22595: Reportbuiler page not visible with page header contionned

Post by bcotting » 16 Nov 2015, 09:58

Hello,
I have a bug with a report with reportbuilder 6.2, this report has no problem with version 4.2.
The page header is conditionned and it's a page break in the first bloc after the page header.
In same cases the content of the first page or some page where the page header is not visible, the page content is not visible (only the page footer is visible).
This with the fist preview or direct print of the report; but in the preview with click on the buton fit page in a window or print from the preview the content is visible normaly.

The phenomen is not the same with different data , same page are visible or not depending of the number or order of page in report.
The page header is conditionned with page number function, with another condition (0), all page are visible normaly.
The problem is the same with condition on all the page header or only on a line of the page header.

I've attached sample wit a report and a script to create the table in database island with data.
The report is linked with the table testdata of database island.

On the first preview, the frist page is not visible, passing the from preview to design and the preview, then content is complet.

Thank you.
You do not have the required permissions to view the files attached to this post.

Jeff Luther
Site Admin
Site Admin
United States of America
Posts: 2366
Joined: 04 Mar 2017, 18:34
Location: Palm Springs, California

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by Jeff Luther » 20 Nov 2015, 20:13

I was able to at least see your RB file and was struck by the long header/footer areas in the report. That may be think that perhaps -- and as a guess it would be a bug, since it worked in v4.2 -- that those long blocks are 'crowding out' any detail or other block which might be why they are (inconsistently) not being displayed.

When you read your 4.2 file into 6.2 RB then there's a chance that 6.2 didn't do rebuild it correctly. There's no 'apt/text' version of an RB file like there is in TD, so the new RB might not have (re)built the report right and if the internal structure changed from 4.2 --> 6.2 this could be the problem..

Here's what I'd do: SAVE A BACKUP OF YOUR CURRENT FILE! And after that, delete the entire contents (not input items, formulas, etc.) of the report in RB and save it as a different name with only the inputs,formulas, etc.

Now start recreating the report itself, step by step or report group by group and see if, as you recreate it if that works. My guess is 6.2 didn't correctly 'upgrade' the old 4.2 file. As you recreate each step/group that you save that file under still another name. That way if you reach a point where the report no longer works you can go back to the last save where that file did work. That should help narrow down if or where there's a problem and more details about where the problem might be.
Jeff Luther @ PC Design
Palm Springs, California

bcotting

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by bcotting » 23 Nov 2015, 07:55

Hello,
the report in the sample was made in reportbuilder 6.2 in intregality

Jean-Marc Gemperle

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by Jean-Marc Gemperle » 11 Dec 2015, 16:34

Hi,

Yes I see the problem indeed first page shows nothing until going from preview to design and preview again and this also using Report builder from TD 6.3 SP1.
Note that opening the cqt and print physically on a PDF printer would at least show the first page and the other so seems to be a print preview issue.
I will check 4.2 but believe it be working

Hence I will enter a defect for this issue

Cheers
JM

Jean-Marc Gemperle

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by Jean-Marc Gemperle » 11 Dec 2015, 16:43

can you provide us the 4.2 CQT ?

bcotting

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by bcotting » 14 Dec 2015, 09:34

Hello,

attached is the 4.2 qrp

Best Regards

bcotting

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by bcotting » 14 Dec 2015, 09:37

Hello,

attached is the 4.2 qrp

Best Regards
You do not have the required permissions to view the files attached to this post.

Jean-Marc Gemperle

Re: TD-22595: Reportbuiler page not visible with page header contionned

Post by Jean-Marc Gemperle » 14 Dec 2015, 11:29

Hi

Here is the issue entered. Obviously switching form preview to design and back to preview making the page appear pretty much implies a defect, furthermore checking the CQT with TD 6.1 SP6 shows it working fine.

TD-22595

Cheers
JM

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests