TD52 crashes after previewing a report

Report bugs and possible workarounds.
Jan Bouma
Netherlands
Posts: 24
Joined: 21 Mar 2017, 14:04
Location: The Netherlands

TD52 crashes after previewing a report

Post by Jan Bouma » 28 Feb 2011, 11:50

TD52 crashes after previewing a report
We have a Print wizard dialog with tabs. When finishing the wizard the default report preview window comes up en shows the report. Then you close the preview window. This stil goes ok. But when clossing our Print Wizard dialog TD52 crashes.

then starting Visual studio for debuging, i get the follwing message:

Unhandled exception at 0x77bc4441 in cbi52.exe: 0xC015000F: The activation context being deactivated is not the most recently activated one.

We have the EMP5321 installed

IN TD42 this works fine ! Their i can repeadly preview the report and close the Print Wizard and open it again and preview the report..

I have a test application, but this is not a small one

Jeff Luther

Re: TD52 crashes after previewing a report

Post by Jeff Luther » 01 Mar 2011, 00:50

We have the EMP5321 installed

IN TD42 this works fine !
How does it run with v5.2 SP2 before the EMP was applied?
TD52 crashes after previewing a report
A/any report? One particular report? Can you create a new report and have it work? Are the QRP file in v4.2 format? Some testing to help find the 'edges' of this problem can help. Also, if you can reduce the test case to something manageable that would help too. How about if you just read in the QRP into RB and Preview from there? Also get a crash?

Jan Bouma
Netherlands
Posts: 24
Joined: 21 Mar 2017, 14:04
Location: The Netherlands

Re: TD52 crashes after previewing a report

Post by Jan Bouma » 02 Mar 2011, 13:00

Before EMP5321 it also crashed.
The reports are in 4.2 Format. It is not only this one . it is with some reports. a lot of reports work fine.
And i tried the same report saved with Reportbuilder52 and it still crahes.
But i dont think is pure the report, it is the combination of our wizard construction and the report. The reports preview is ok. And the preview is already closed.
It crashes just after closing the our wizard dialog. First i thought it was a some events firing as crazy. But after debuging and commenting some things,
i cant get any information more about what it could be.

the example is big because a lot of code is pulled in because of unresolved variables.
The code to run is just 1 dialog box ( the wizard ) that wil preview the report. I merged all apl's in to one app.
We use Sybase SqlAnywhere 11 or 12 so you wil need a database file which i can upload to you.
Sybase has a free developers version.

Jeff Luther

Re: TD52 crashes after previewing a report

Post by Jeff Luther » 02 Mar 2011, 19:56

I suggest you try to put a test case together that doesn't need a DB, perhaps has a few rows of data in the TD app. that are used to populate the report.
The reports are in 4.2 Format
I would also suggest keeping a backup of all these and then try reading in a couple into RB v5.2, trying Preview mode (to see that something appears) and saving out as v5.2 reports. Then try your appl. + reporting again using these updated QRP files.
our wizard dialog
This you will need to explain further.

Jan Bouma
Netherlands
Posts: 24
Joined: 21 Mar 2017, 14:04
Location: The Netherlands

Re: TD52 crashes after previewing a report

Post by Jan Bouma » 03 Mar 2011, 14:19

Your suggestion to try it with out report data was a good one.
After Disabeling the report to come up i still had a crash.
Now i saw that a call to GetLocaleInfoW was the one that gave a delayed crash. I changed it in GetLocaleInfoA and no crash any more.

Thanks for your help. i'am sorry that i took up your time.

Return to “Bug Reports”

Who is online

Users browsing this forum: [Ccbot] and 0 guests