forum.gupta.bugreport (2005-2010)
Jostein Bjørkøy


Post by Jostein Bjørkøy » 03 Jul 2008, 10:21

 Posted by:  Jostein Bjørkøy 

After installing TD5.1 sp3, SqlTalk doesn't work any more. I get a dialog
box with the title: Sql Error 135, and 135 as the only message.
Please let me know how to fix this.

Regards Jostein Bjørkøy

Posts: 2216
Joined: 09 Mar 2017, 05:32
Location: Hyderabad, India

Re: SqlTalk

Post by FRBhote » 03 Jul 2008, 10:58

 Posted by:  F R Bhote 

No on at Unify sees this anymore - although I bet that at least two do so -
Mike & Jeff - out of old habits not dying hard!


Jeff Luther
Site Admin
Site Admin
United States of America
Posts: 2370
Joined: 04 Mar 2017, 18:34
Location: Palm Springs, California

Re: SqlTalk

Post by Jeff Luther » 03 Jul 2008, 17:03

 Posted by:  Jeff Luther 

Well, I don't know the internals of how SQLTalk gets itself set up, Jostein,
but I see from #135 that:
00135 SQL ICN Invalid cursor number
Reason: The application program is attempting to perform a function call and
is using an invalid cursor number. Or, the application program may be using
an old or mismatching version of a .DLL file. Also, if this is a shared
cursor, it may be that the shared cursor is no longer valid because the
owner application has been terminated.

The "old or mismatching version of a .DLL file" might be a clue. Where are
you running SQLTalk? It's a little confusing because I see on my std. setup
that there's a SQLTalk in my TD install directory. There's also a SQLTalk in
the SQLBase directory, which is under the TD install dir.

I have a shortcut in a desktop folder that points to the SQLBase version,
though I just d-clicked on the one in the TD dir. and it loaded ok as well.
Check to be sure all the DLLs have the same date. for my SP2 I have them
dated 4/4/2008.

"let me know how to fix this" - Maybe Mike V. will visit here and expand on
my reply, but at be sure of the dates of the DLLs and that your sql.ini is
still correct.

Best regards,
Jeff Luther
Unify Corporation

Mike Vandine

Re: SqlTalk

Post by Mike Vandine » 05 Jul 2008, 01:09

 Posted by:  Mike Vandine 

Hi Jostein,

'Doesn't work anymore' implies that it worked before. Do you get the
message as soon as SQLTalk starts, on a connect, etc.?

Check the 'Options/session settings' to make sure that it's pointing to the
correct sql.ini file.

Can you please post a screenshot.

When you installed TD, which version of SQLBase did you install?

And lastly, please use the new forums if you really want more than just 3
people to look at your postings. Simply go to:


You will need to register to do any posting, but it's free and doesn't take
long to do. There are *heaps* of forums there and I'm sure you'll get a
better response from the community there.

Best regards,


Jostein Bjørkøy

Re: SqlTalk

Post by Jostein Bjørkøy » 17 Jul 2008, 09:15

 Posted by:  Jostein Bjørkøy 

Thank you all for your help. The problem is now solved because of the advice
in the first reply. I copied the dll's from an other machine running TD5.1
installed from scratch, and the problem was solved. I don't know why the
dlls was wrong.On my machine I installed the first availible verion of TD5.1
and after that installed the sp1,2,3. On the other machine, running Vista,
TD5.1 was installed later. May be there is somthing here.


Return to “gupta.bugreport”

Who is online

Users browsing this forum: [Ccbot] and 0 guests