Microsoft CDO For Exchange 2000 Library.apl / Microsoft CDO for Windows 2000 Library.apl

forum.gupta.bugreport (2005-2010)
K. Arkenberg

Microsoft CDO For Exchange 2000 Library.apl / Microsoft CDO for Windows 2000 Library.apl

Post by K. Arkenberg » 17 Jul 2006, 11:39

 Posted by:  K. Arkenberg 

Hi all,
why do the libraries for CDO not work on a remote SMTP-Server when no local
SMTP exists?
I tried to use Microsoft CDO for Windows
2000 Library.apl for sending Emails. My application works fine on a client
with local SMTP, it is also working, when I tell the application a remote
server-name (with or without authentification). But it is not working with a
remote SMTP-Server after deinstalling the local SMTP and deleting mailroot.
By starting SendUsing-Method, I get the errormessage:
error code at invocation of Send: 80020009
Source: CDO.Message.1
Error Description: "SendUsing" configuration-value ist wrong.
Sending Emails over CDO with a .NET application (with same paramters) or
an excel-spreadsheed works fine also with a remote SMTP, so it is not a
rights-permission or configuration problem.

I didn`t find anything about this problem in the web, so I think it is a
special problem of Gupta. (I tried the versions 1.51, 3.00, 3.01) I also
tried my library on an exchangeserver (without a local SMTP) and the
cdoex.dll (and not the cdosys.dll), unfortunately with the same error. Is
this a bug or why do I not get it running? Is it really nessesary to use
winsock-functions like in the samples of Astor and Beltrame?

In .NET there is an object called SmtpMail, is there anything
encapsulated for Gupta?

best regards

Kerstin

Return to “gupta.bugreport”

Who is online

Users browsing this forum: [Ccbot] and 0 guests