OLEDB to MS SqlServer with TD2005.1

forum.gupta.bugreport (2005-2010)
RainerE
Germany
Posts: 2223
Joined: 27 Apr 2021, 12:40
Location: Germany

OLEDB to MS SqlServer with TD2005.1

Post by RainerE » 14 Sep 2005, 18:03

 Posted by:  Rainer Ebert 

I've test application build with TD2.1PTF4 which is able to connect to MS
SqlServer 2000 SP4 via OLEDB. If I execute the unchanged application on the
same PC with TD2005.1 (instead of TD2.1) I'm not able to connect to
SqlServer. I'm getting the following error message:
"[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access
denied.".

Info: Connecting to SqlServer via native/ODBC-Router is possible with TD2.1
and TD2005.1.

What is wrong?

Rainer

RainerE
Germany
Posts: 2223
Joined: 27 Apr 2021, 12:40
Location: Germany

Re: OLEDB to MS SqlServer with TD2005.1

Post by RainerE » 15 Sep 2005, 15:55

 Posted by:  Rainer Ebert 

I've made some more tests:
- I've installed TD3.1 and tested OLEDB -> working properly
- I've installed TD2005 and testes OLEDB -> same problem as with TD2005.1

So I can say, that something regarding OLEDB has changed in TD2005.

Can someone tell me what I have to do to use OLEDB to connect to
SqlServer2000 in TD2005?

Regards,
Rainer

RainerE
Germany
Posts: 2223
Joined: 27 Apr 2021, 12:40
Location: Germany

Re: OLEDB to MS SqlServer with TD2005.1

Post by RainerE » 16 Sep 2005, 09:49

 Posted by:  Rainer Ebert 

I've found the reason:
Starting with TD2005, OLEDB only works if you leave the variables
SqlDatabase, SqlUser and SqlPassword empty. In earlier versions of TD, this
problem does not exist.

But the documentation still says, that you can use those variables.

Please correct this problem - if possible in the next PTF.

Rainer

Jim McNamara

Re: OLEDB to MS SqlServer with TD2005.1

Post by Jim McNamara » 16 Sep 2005, 15:29

 Posted by:  Jim McNamara 

Not so to Oracle in TD2005

Lubos Vnuk

Re: OLEDB to MS SqlServer with TD2005.1

Post by Lubos Vnuk » 18 Sep 2005, 04:54

 Posted by:  Lubos Vnuk 

Nor for DB2 UDB (Provider=IBMDADB2) in TD2005.1

Return to “gupta.bugreport”

Who is online

Users browsing this forum: [Ccbot] and 0 guests