WISH: function naming convention

forum.wishlist (1998-2005) & forum.gupta.wishlist (2005-2010)
Martin Jussel

WISH: function naming convention

Post by Martin Jussel » 25 Sep 2003, 11:10

 Posted by:  Martin Jussel 


Coding Assistant would be a nice thing if you name the functions more
consequential. Currently you have to search table column functions by
scrolling up and down (e.g. SalTblCreateColumn,
SalTblDefinePopupEditColumns, SalTblGetColumWindow). It would be much better
if one of the guptas thought about a naming convention for function names.
My suggestion:

1. parent/children logic. e.g.
table functions have to start with SalTbl...
table column functions have to start with SalTblColumn...
table row functions have to start with SalTblRow...

2. clear get/set logic instead of get, set, query, define, ...
after parent/children logic the next part of the name is "Get" or "Set"

The result:
SalTblColumnCreate() instead of SalTblCreateColumn()
SalTblColumnSetPopupEdit() instead of SalTblDefinePopupEditColumns()
SalTblColumnGetWindow() instead of SalTblGetColumnWindow()

I think this naming convention would be more logical for developers (think
about the "newbie" who needs to find a function!) and better for sorting in
"Coding Assistant".

Igor Ivanovic
Site Admin
Site Admin
Posts: 1243
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

WISH: function naming convention

Post by Igor Ivanovic » 25 Sep 2003, 16:27

 Posted by:  Igor Ivanovic 

I second that, too.


Lubos Vnuk

WISH: function naming convention

Post by Lubos Vnuk » 26 Sep 2003, 10:34

 Posted by:  Lubos Vnuk 

This brings one to thinking we'd be better-off crossposting
to get our wishes come true ;o)


Ivar M. Yrke

WISH: function naming convention

Post by Ivar M. Yrke » 26 Sep 2003, 11:15

 Posted by:  Ivar M. Yrke 

Good suggestion. And don't forget similar cases such as
SalGetWindowText->SalWindowGetText (compared to SalStatusGetText whic is
SalSendClassMessage compared to SalSendMsg. Use Msg or Message consequently
and perhaps SalMsgSend in stead of SalSendMsg.

"Martin Jussel" skrev i melding


WISH: function naming convention

Post by Sepp » 26 Sep 2003, 13:32

 Posted by:  Sepp 

Hello NG,

i think, this discussion should be stopped!
I do not find it worth wasting diskspace!
Just think of the smashing number of other entries in WishList, just think
of Reportbuilder:
- so many things to do for Gupta!!
- so many things to talk about in Forum, before Gupta starts working on
Changing the present funciotnnamens would only needlessly increase the
problems we have with the known deficiencies of CTD.
I do not remember many Entries, which have 10 follow-ups.
Remember: this is forum for developers, not a chatroom.

Have fun with Centura


Martin Jussel

WISH: function naming convention

Post by Martin Jussel » 26 Sep 2003, 16:14

 Posted by:  Martin Jussel 


Thank you very much for your useful contribution.


Jarmo Muukka

WISH: function naming convention

Post by Jarmo Muukka » 13 Oct 2003, 15:36

 Posted by:  Jarmo Muukka 

I'm glad to see that at least one thinks in OO way. Unfortunately they have
to develop a tool that is backward compatible. But, other companies are
doing new systems that are not backward compatible. If you have tons of ASP
code, do you convert it to ASP.NET? Maybe someone does, but the result is a
mess as ASP is a mess. But ASP.NET is well designed, so with proper design
you get nice web apps.

Ideally I would like to see the things that you suggested and that the tool
would generate normal Windows runtime, perhaps built on .NET and the same
tool would generate web pages too (html). And that tool would implement OO
as it is implemented in C#. Hiding, properties, interfaces, etc.


Return to “gupta.wishlist”

Who is online

Users browsing this forum: [Ccbot] and 0 guests