Centura 1.5.1 + SQL Server 2000 + MDAC 2.8

forum.centura.team.developer (1998-2005) & forum.sqlwindows (2000-2005)
BFESTA

Centura 1.5.1 + SQL Server 2000 + MDAC 2.8

Post by BFESTA » 03 Apr 2006, 21:55

 Posted by:  BFESTA <bfe...@markelcorp.com> 

Hello,

I am currently working on converting our in house application to
connect from Oracle to SQL Server. With Oracle we used to use the
Oracle client and my goal was to use the ODBC tool to connect for SQL
Server. However I am running into some trouble.

The development tool is Centura 1.5.1
The operating system is Windows XP SP2
The server is SQL Server 2000

I have a service account created on the SQL Server and none of the
Active Directory accounts are given any access to the SQL Server. The
goal is to have the application log them in through this service
account. I have already created a System DSN which points to the SQL
Server using the ODBC tool built into windows. The account
successfully works there. But when I attempt to connect from Centura
by just doing:

! Obviously not actual code
Set SqlUser = 'ServiceAccount'
Set SqlPassword = '12356789LongPassword'
Set SqlDatabase = 'ODBC Name'
Call SqlConnect(sqlHandle)

The problem that occurs is that it never passes in the SqlUser or
SqlPassword for the connection string on the ODBC connect. It ends up
just ending my Windows Authentication information instead. When I ran
this in Windows 2000 under the MDAC 2.7 (or was it 2.6?) back in 2004 I
did not experience this issue. The exact same basic logic worked. Or
at least I seem to think I remember it working.

Please any help would be greatful, as the due date is not very far away
and I am stuck dead in the water with out this working.

Return to “forum.sqlwindows”

Who is online

Users browsing this forum: [Ccbot], [Google] and 0 guests