Wrong interface after compiling

Discussion forum about all things Team Developer 5.x and 6.x
gigit
Italy
Posts: 152
Joined: 14 Jun 2017, 15:04
Location: Italy

Wrong interface after compiling

Post by gigit » 08 Mar 2019, 10:12

Hi to all.
After a system crash I needed to reinstall 6.0 ptf 8 version. Now, for every kind of interface I choose at runtime (office 2010, office 2007, native windows XP and so on) when compiled the .EXE has always the same interface. Blue and I cannot change it.
Any Hint?
Thank you.


Gigi
You do not have the required permissions to view the files attached to this post.

thomas.uttendorfer
Site Admin
Site Admin
Germany
Posts: 198
Joined: 05 Mar 2017, 17:19
Location: Munich Germany

Re: Wrong interface after compiling

Post by thomas.uttendorfer » 08 Mar 2019, 16:49

Hi Gigit,

we set the theme on SAM_AppStartup with SalThemeSet(..).
That should be a stable solution.

Regards Tom
Thomas Uttendorfer
[ frevel & fey ] Software-System GmbH
https://thomasuttendorfer.wordpress.com/

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 2928
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: Wrong interface after compiling

Post by Dave Rabelink » 08 Mar 2019, 19:22

Are you sure you have set the theme in the build settings of the apt/app ?

BuildSettings.png
You do not have the required permissions to view the files attached to this post.
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

gigit
Italy
Posts: 152
Joined: 14 Jun 2017, 15:04
Location: Italy

Re: Wrong interface after compiling

Post by gigit » 11 Mar 2019, 10:31

Hi Dave, many thnaks. That was set to Default @#@#! :evil:

I completely forgot this.
Thank you.

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests