Solved Application with Oracle > 12c - server-side alert log entry for each connect

Discussion forum about all things Team Developer 5.x and 6.x
JonasK
Germany
Posts: 8
Joined: 01 Feb 2019, 15:22
Location: Germany

Application with Oracle > 12c - server-side alert log entry for each connect

Post by JonasK » 14 Aug 2020, 15:14

Hello folks,

our application currently is running fine under Oracle-versions from 10g to 18c. Within Oracle 12c and 18c each connect generates an server-side alert log entry:

Code: Select all

<error barrier> at 0x00000087092B15F0 placed gwm.c@2384
ORA-24962: Verbindungszeichenfolge konnte nicht geparst werden, Fehler = 303
The same issue in combination with TD is mentioned in an Oracle-Community-thread (https://community.oracle.com/thread/4304827, login required), but without solution. I also checked the OpenText-Knowledge-Base, but couldn't find any useful information. Do you have any idea how to fix this problem?

Regards,
Jonas

Michael Ehehalt
Germany
Posts: 73
Joined: 13 Mar 2017, 09:17
Location: Frankfurt, Germany

Re: Application with Oracle > 12c - server-side alert log entry for each connect

Post by Michael Ehehalt » 10 May 2022, 15:05

Hi Jonas,

we have the same error now with Oracle 19c. Was there a solution to the problem?
Best regards,
Michael Ehehalt

TWitte
Germany
Posts: 73
Joined: 06 Nov 2017, 13:07
Location: Unterhaching

Re: Application with Oracle > 12c - server-side alert log entry for each connect

Post by TWitte » 11 May 2022, 09:40

Hi,

we have absolutely no problem with 12c or 19c.
Do you mind to send me a testcase to analyze. Maybe I can help.
Timo Witte
BPCS Consulting Services

Michael Ehehalt
Germany
Posts: 73
Joined: 13 Mar 2017, 09:17
Location: Frankfurt, Germany

Re: Application with Oracle > 12c - server-side alert log entry for each connect

Post by Michael Ehehalt » 11 May 2022, 10:08

Hi,

all our Team Developer applications produces the errors in the trace files, but the applications runs without problems. :?
A sample that only connects to the database don't produce the error. If I have a sample that produces the error too, I could send a test case (or I have the solution ;) )

We use the Team Developer 7.4.1 on an Oracle 19c database.

> Do you mind to send me a testcase to analyze. Maybe I can help.
Thanks for the support :)
Best regards,
Michael Ehehalt

Michael Ehehalt
Germany
Posts: 73
Joined: 13 Mar 2017, 09:17
Location: Frankfurt, Germany

Re: Application with Oracle > 12c - server-side alert log entry for each connect

Post by Michael Ehehalt » 15 Jun 2022, 13:19

Hi,

it seems, the problem is solved. We had the following entries in the sql.ini:
[oragtwy]
remotedbname=xe,@tns:xe
With this, we could connect to the database "xe" without problems from the applications, but with the alert log entries. After removing the "tns:"-part and changing the sql.ini entries to:
[oragtwy]
remotedbname=xe,@xe
the errors are gone. :) (No idea why we had the "tns"-part ...)
Best regards,
Michael Ehehalt

Return to “General Discussion”

Who is online

Users browsing this forum: [Ccbot] and 0 guests