TD-24337: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Report bugs and possible workarounds.
WantToBeRich
Germany
Posts: 16
Joined: 20 Nov 2018, 08:16
Location: Munich, Germany

TD-24337: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by WantToBeRich » 07 Jan 2019, 11:13

Hallo,

after the update to the 7.1.1 we have a big issue on all Child grids.

After user press the "Insert key", normale a new row was added to the grid. For every insert-key the message WM_KEYUP was send and I can handle this.

After update to 7.1.1, this works only the first time!!! If the first row was inserted, the next time the focus is switching to the first data field..

I can generate a very small test programm to simulate this issue - but I was not able to attach it here?

Is there any workaround for this bug?

Kind regards

Andreas

Dave Rabelink
Founder/Site Admin
Founder/Site Admin
Netherlands
Posts: 1232
Joined: 24 Feb 2017, 09:12
Location: Gouda, The Netherlands

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by Dave Rabelink » 07 Jan 2019, 11:21

WantToBeRich wrote:
07 Jan 2019, 11:13
...but I was not able to attach it here?
You have to ZIP the sample and upload that as attachment.
Regards,
Dave Rabelink

Image
Articles and information on Team Developer Tips & Tricks Wiki
Download samples, documents and resources from TD Sample Vault
Videos on TDWiki YouTube Channel

WantToBeRich
Germany
Posts: 16
Joined: 20 Nov 2018, 08:16
Location: Munich, Germany

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by WantToBeRich » 07 Jan 2019, 11:56

zip file attached
You do not have the required permissions to view the files attached to this post.

Igor Ivanovic
Site Admin
Site Admin
Croatia
Posts: 811
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by Igor Ivanovic » 07 Jan 2019, 15:06

You are right, definitely a regression in 7.1.1.
It works ok in 6.3 and 7.0.

I don't like the fact that there is no visible info that the grid has focus as the table has, so I am using the child table whenever I need the user to enter some info and the grid for previews...

But I think that we ARE using a grid in some modules to enter data and they don't work anymore :evil:
And I have an important presentation of our new software tomorrow and no time to switch to the table...

Well I found out a workaround: if holding Ctrl or Shift or Alt the insert will not be eaten, so at least for tomorrow I have a way to avoid it.
But for end users who are accustomed with the INS key to enter a new row of data in the table it will be a problem-
Igor Ivanovic
Image

WantToBeRich
Germany
Posts: 16
Joined: 20 Nov 2018, 08:16
Location: Munich, Germany

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by WantToBeRich » 07 Jan 2019, 15:23

Dear Igor,

the workaround with Ctrl or Shift works for me - Alt not.

I our case - we just switched yesterday in production to 7.1.1. Extremly nice bug in the new year…

It would be better to find out which DLL was faulty and switch this DLL back to 7.1.0 ?

Thanks

Andreas

WantToBeRich
Germany
Posts: 16
Joined: 20 Nov 2018, 08:16
Location: Munich, Germany

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by WantToBeRich » 07 Jan 2019, 17:05

the faulty DLL was the CDLLI71.DLL. If I switch this DLL to the 7.1.0 reverse - it works, but nobody knows the side-affects. So I´m waiting for a bugfix from OpenText and the user should use in the meantime Ctrl + Insert or Shift + Insert.

Igor Ivanovic
Site Admin
Site Admin
Croatia
Posts: 811
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by Igor Ivanovic » 09 Jan 2019, 06:01

Andreas,

It is not a good idea to switch to an 7.1.0 cdlli71.dll as it could produce some strange side effects.
Did you entered a ticket for the bug?
Igor Ivanovic
Image

WantToBeRich
Germany
Posts: 16
Joined: 20 Nov 2018, 08:16
Location: Munich, Germany

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by WantToBeRich » 09 Jan 2019, 08:21

actual not, because I think Gupta ist reading here too and the subject is clear.

They should know what to do....

But if you want, you can report the bug and the sample directly :)

Igor Ivanovic
Site Admin
Site Admin
Croatia
Posts: 811
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

Re: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by Igor Ivanovic » 09 Jan 2019, 09:30

I don't know for sure if anybody from Gupta is reading this forum, hopefully it does, but I do not know for sure that if you don't open the ticket the bug will not be addressed.
That's the way things are.
Anyway I opened the ticket (#4064347 ) and sent your repro.

Cheers
Igor Ivanovic
Image

Igor Ivanovic
Site Admin
Site Admin
Croatia
Posts: 811
Joined: 05 Mar 2017, 12:37
Location: Zagreb, Croatia

Re: TD-24337: On Child Grid Keyboard entries INSERT doesn´t work in 7.1.1

Post by Igor Ivanovic » 10 Jan 2019, 08:40

FYI, OpenText has assigned a defect number to the bug : TD-24337
Igor Ivanovic
Image

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 0 guests