ReportBuilder3.0 Invalid Print Command

Discussion forum about all things Report Builder (all versions).

ReportBuilder3.0 Invalid Print Command

Post by tiger » 29 Feb 2008, 03:25

Product: Gupta Team Developer 3.0 (PTF4)
ReportBuilder 3.0
OS:Windows XP SP2

My project is Client/Server Structure. One client runned error when printing label which you can see in my attachment. And we found all the labels couldn't be printed normally even in different modules on that PC.
And the programs on this client were not updated and other clients are always normal like before.
And in order to solve this error we have tried serveral methods, such as restarting OS, uninstalling and reinstalling Gupta and pactching the PTF4.And they all failed.
Some days ago we met this error and we solved it by reinstall OS finally, but as you know it's so unconvenient.
Could you please be so kind to tell me some advices? Thank yo so much for your kind help in advance!

Best regards
You do not have the required permissions to view the files attached to this post.
Last edited by tiger on 29 Feb 2008, 10:55, edited 1 time in total.

Mike Vandine

Re: ReportBuilder3.0 Invalid Print Command

Post by Mike Vandine » 29 Feb 2008, 07:48

I have seen this error message pop up with this version when there are no printers defined on the PC. Could this be the case here?

Best regards,


Re: ReportBuilder3.0 Invalid Print Command

Post by tiger » 29 Feb 2008, 10:59

Thank you very much for your kind reply!
But I think our error was not this cause, the client can print normally using other software such as printing MS word.
Do you have other advice? Thank you again!
Best wishes,


Posts: 328
Joined: 01 May 2019, 08:04
Location: Germany

Re: ReportBuilder3.0 Invalid Print Command

Post by Geert_Schröder » 29 Feb 2008, 12:06

Hello tiger

I guess your program sets the windows default printer to a special
printer (maybe a networkprinter) before calling SalReportPrint()-function
and that on the not correct printing client the printername of that printer
is not defined.

Look on that client under windows-systemcontrol\printers if the printername
exists. Maybe the physical printer exists there but under a wrong name.
(If the name is wrong just change/overwrite it to the correct name.)

Best Regards


Re: ReportBuilder3.0 Invalid Print Command

Post by Stefan_Arnold » 29 Feb 2008, 15:43

Hi tiger

Maybe your report template (QRP) uses a special printer who doesn't exists on that PC. You can avoid this problem by checking the checkbox "Use Default Printer" in Report Properties (Menu Report -> Format -> Report...)

Best regards


Re: ReportBuilder3.0 Invalid Print Command

Post by tiger » 03 Mar 2008, 08:53

Thank you very much for all your help!
After we uninstalled and reinstalled Gupta, it's useless!
At lase we solved this error by deleting printer and adding the printer again.
Let's continue to keep in touch!
Best wishes,


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 0 guests