[SP1] Crash of Report Builder 6.1

Discussion forum about all things Report Builder (all versions).
rentz

[SP1] Crash of Report Builder 6.1

Post by rentz » 26 Jun 2012, 14:40

Hi,

Report Builder 6.1 crashes if you click on the ribbon bar button "Groups" whereas the context menu Properties of the Break Groups within Report Objexts does function normally. This happens with any kind of *.qrp file.
The error already appeared without SP1. But unfortunately no change there.

Slightly funny extra: The crash message appears four times and shows the window title "ReportBuilder 6.0". Seems like the version management has overlooked something.

Ralf Entz
Materna TMT GmbH

Jeff Luther

Re: [SP1] Crash of Report Builder 6.1

Post by Jeff Luther » 26 Jun 2012, 23:23

Ralf -- I would like to reproduce this but I see no "Groups" button on the Ribbon Bar, not on any of submenu sections under File, Edit, View, Report, Window.
OOHHH... maybe you mean Report/"Break Groups' -- I'll bet that's it. Now to find a QRP with a break group in it!

Well, I just put together a test CQT for ISLAND/COMPANY table and cannot repro. this crash. I clicked Break Groups initially -- before I had defined one -- and no problem. Added STATE, changed the CQT so there's a title + redefined query for sort by STATE and tried again.

No crash.

QUESTION: Did you do a patch/upgrade of SP1 by applying SP1 over your base 6.1 installation? If so, I strongly suggest you UNinstall 6.1, then do a full/complete install and try again.

I've attached my test query CQT file. It requires local SQLBase with ISLAND DB. See if this works for you. Otherwise, after doing a full/complete install of SP1 and you still have a problem, if you can repro. in a QRP or CQT I would like to get a copy. Thanks.
You do not have the required permissions to view the files attached to this post.

rentz

Re: [SP1] Crash of Report Builder 6.1

Post by rentz » 27 Jun 2012, 07:06

I just checked again and there was indeed a little misunderstanding on my side. The crash does not accur trying to open the Break Group properties but by trying to show the Groups in the "View" menu (which are not the break groups). You can check it even with the newrep.qrp in the templates directory. It crashes with every *.qrp (i don't know about *.cqt files because we don't use them).

And yes, i did install the SP1 over an existing 6.1 installation and really don't see the benefit in always deinstalling the main program before installing a patch (btw, as i wrote, the error occurred even with the unpatches version).

Ralf Entz
Materna TMT GmbH

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 0 guests